EC Running Too High?

Discussion in 'Cannabis Pests and Problems' started by ShadowAD, May 5, 2007.

  1. ShadowAD

    ShadowAD Member

    Hello All,



    Hope you can help me with a problem I'm having with the EC. I am in the 3rd week of bloom, plants have started heading on time for the last week.



    Setup:



    Have EC set at 1.8 and Ph 6.1

    Growing room with 1000w

    Avg temp 27-29 cel

    Medium - clay balls & perlite

    Running pump watering system, feeding 30 minutes, 5 times daily



    For some reason my EC raises almost after every feed. If left without adding water to tub for a day or two, EC goes from 1.8 to as high as 2.5.



    Thanks for your feedback everyone. :)
     
  2. fishheadbob

    fishheadbob Member

    Sounds like your plants are taking up water and somehow not as much nutrient. The water is being used, but the nutrient is left behind, somehow, giving you a higher concentration in the remaining solution than you want. Maybe try adding a little less nutrient to your water. Watch the plants overall to see that they maintain the good shade of green you most likely have. Overfertilizing is always a good place to look for problems.
    Also sounds like your room temp and ph might be a shade high.
     

Share This Page


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice